Re: UTS_VERSION unmatched

From: Paul H. Hargrove (PHHargrove_at_lbl_dot_gov)
Date: Tue Sep 09 2008 - 13:23:51 PDT

  • Next message: Jin Zhang: "BLCR Error"
    Hideyuki Jitsumoto,
    
      What the message you see is telling us is that the kernel you are 
    running was built on Jun 17, but that the kernel sources used to build 
    BLCR were configured on Aug 18.  This means that it is possible that the 
    two do not match.  This check of UTS_VERSION was added to 0.7.0, and was 
    not present in the 0.6.x series.  It was added because there were 
    reports of the  BLCR kernel modules loading into non-matching kernels 
    and causing odd kernel behavior (including crashes and possible data 
    corruption).  This was happening mostly when distros released versions 
    with very small changes (such as security fixes) that escaped detection 
    by our weaker address-based kernel validation mechanism.
    
      I would suggest that as a first step, you check that the full package 
    version of linux-headers and linux-image match.  I just downloaded the 
    following:
    http://security.debian.org/debian-security/pool/updates/main/l/linux-2.6/linux-image-2.6.18-6-686_2.6.18.dfsg.1-22etch2_i386.deb
    http://security.debian.org/debian-security/pool/updates/main/l/linux-2.6/linux-headers-2.6.18-6-686_2.6.18.dfsg.1-22etch2_i386.deb
    and I find that both have the Aug 18 UTS_VERSION.  So, I suggest you 
    look to either update your linux-image package, or perhaps the installed 
    package is correct but a reboot may be required to load the new kernel.
    
      If you still have trouble and are willing to risk some trouble, you 
    could disable this check by making a 1-line change.  Change line 74 of 
    blcr_imports/module.c from
    
      #ifdef UTS_VERSION /* Often NOT available in configured kernel headers */
    
    to
    
      #if 0
    
    
    
    -Paul
    
    
    Hideyuki Jitsumoto wrote:
    > Dear BLCR_ML_Users,
    >
    > I installed BLCR on Debian/Etch.
    > (result of uname -a is
    >  Linux pad203 2.6.18-6-686 #1 SMP Tue Jun 17 21:31:27 UTC 2008 i686 
    > GNU/Linux.
    >  and I used newest linux-headers-2.6.18-6-686.deb
    > )
    > I can use BLCR 0.6.5 and before in my environment, but I can not use 
    > 0.7.0 and later.
    > In that case , i got "Invalid parameter" on loading blcr_import.ko
    > i checked dmesg and found following.
    >
    > Running kernel UTS_VERSION (#1 SMP Tue Jun 17 21:31:27 UTC 2008) does 
    > not match that used to build BLCR (#1 SMP Mon Aug 18 08:42:39 UTC 2008)
    >
    > Should I need to match kernel uts_version and blcr (kernel_header) one ?
    > If I don't need, please tell me how to use BLCR 0.7.0 and later.
    >
    > Thank you ,
    > Hideyuki Jitsumoto
    > -- 
    > Sincerely Yours,
    > Hideyuki Jitsumoto (jitumoto@matsulab.is.titech.ac.jp 
    > <mailto:jitumoto@matsulab.is.titech.ac.jp>)
    > Tokyo Institute of Technology
    > Global Scientific Information and Computing center (Matsuoka Lab.)
    
    
    -- 
    Paul H. Hargrove                          PHHargrove_at_lbl_dot_gov
    Future Technologies Group                 
    HPC Research Department                   Tel: +1-510-495-2352
    Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900
    

  • Next message: Jin Zhang: "BLCR Error"