Fwd: Bug#542643: Does not build with 2.6.30-1-686

From: Alan Woodland (alan.woodland_at_gmail_dot_com)
Date: Sat Aug 22 2009 - 02:43:01 PDT

  • Next message: Paul H. Hargrove: "Re: Fwd: Bug#542643: Does not build with 2.6.30-1-686"
    Hi,
    
    A user just reported this. Is it a known problem, or Debian specific?
    
    Thanks,
    Alan
    
    ---------- Forwarded message ----------
    From: Anthony DeRobertis <anthony_at_derobert_dot_net>
    Date: 2009/8/20
    Subject: Bug#542643: Does not build with 2.6.30-1-686
    To: Debian Bug Tracking System <submit_at_bugs_dot_debian_dot_org>
    
    
    Package: blcr-source
    Version: 0.8.2-2
    Severity: normal
    
    configure: error: Failed to locate kernel symbol table.  Try using
    --with-system-map or --with-vmlinux.
    
    This seems to be from using:
    
     if test -n "$cr_file" -a -r "$cr_file" && grep ' [AB] _end'
    <"$cr_file" >/dev/null 2>/dev/null; then
    
    to check if a System.map file is valid. The System.map file shipped with
    2.6.30-1-686 does not contain an _end. Removing the test makes the build
    succeed and a quick test of suspending/resuming "cat" works.
    
    
    -- System Information:
    Debian Release: squeeze/sid
     APT prefers testing
     APT policy: (500, 'testing'), (500, 'stable'), (100, 'unstable')
    Architecture: i386 (i686)
    
    Kernel: Linux 2.6.30-1-686 (SMP w/2 CPU cores)
    Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
    Shell: /bin/sh linked to /bin/bash
    
    Versions of packages blcr-source depends on:
    ii  bzip2                         1.0.5-3    high-quality block-sorting file co
    ii  debhelper                     7.3.12     helper programs for debian/rules
    ii  make                          3.81-6     An utility for Directing compilati
    ii  module-assistant              0.11.1     tool to make module package creati
    
    blcr-source recommends no packages.
    
    blcr-source suggests no packages.
    
    -- no debconf information
    

  • Next message: Paul H. Hargrove: "Re: Fwd: Bug#542643: Does not build with 2.6.30-1-686"